[CMake] set RPATH for plugins

to fix debian packages creation on ROS buildfarm:

00:12:11 dpkg-shlibdeps: error: cannot find library libtracer.so.4.3.1 needed by
debian/ros-noetic-dynamic-graph/opt/ros/noetic/lib/dynamic-graph-plugins/libtracer-real-time.so.4.3.1
(ELF format: 'elf64-x86-64' abi: '0201003e00000000'; RPATH: '')
7 jobs for pr/83 in 3 minutes and 49 seconds (queued for 1 second)
Status Name Job ID Coverage
  Test
passed doc-coverage #102235

00:03:48

93.0%
passed format #102236

00:00:12

passed robotpkg-dynamic-graph-v3-16.04-release #102230

00:01:34

passed robotpkg-dynamic-graph-v3-18.04-release #102231

00:01:49

passed robotpkg-dynamic-graph-v3-20.04-release #102232

00:02:03

passed robotpkg-dynamic-graph-v3-buster-release #102233

00:01:47

passed robotpkg-dynamic-graph-v3-stretch-release #102234

00:01:58