[CMake] drop eigen version requirement

As on 16.04, /usr/lib/cmake/eigen3/Eigen3Config.cmake is not giving any.
8 jobs for v1.1.2 in 10 minutes and 26 seconds (queued for 3 seconds)
latest
Status Name Job ID Coverage
  Test
passed doc-coverage #67016

00:10:11

84.0%
passed format #67017

00:10:09

passed robotpkg-eiquadprog-16.04-debug #67011

00:09:41

passed robotpkg-eiquadprog-16.04-release #67010

00:09:23

passed robotpkg-eiquadprog-18.04-debug #67013

00:10:19

passed robotpkg-eiquadprog-18.04-release #67012

00:09:26

passed robotpkg-eiquadprog-stretch-debug #67015

00:10:13

passed robotpkg-eiquadprog-stretch-release #67014

00:09:56