Unverified Commit 8833b016 authored by Justin Carpentier's avatar Justin Carpentier Committed by GitHub
Browse files

Merge pull request #196 from wxmerkt/wxm-package-xml-compatibility

package.xml: Add exec_depend on catkin or ament_cmake
parents a7394997 7e786d7a
...@@ -4,7 +4,7 @@ ...@@ -4,7 +4,7 @@
<version>2.4.1</version> <version>2.4.1</version>
<description>Bindings between Numpy and Eigen using Boost.Python</description> <description>Bindings between Numpy and Eigen using Boost.Python</description>
<maintainer email="justin.carpentier@inria.fr">Justin Carpentier</maintainer> <maintainer email="justin.carpentier@inria.fr">Justin Carpentier</maintainer>
<maintainer email="wolfgang.merkt@ed.ac.uk">Wolfgang Merkt</maintainer> <maintainer email="wolfgang@robots.ox.ac.uk">Wolfgang Merkt</maintainer>
<author>Justin Carpentier</author> <author>Justin Carpentier</author>
<author>Nicolas Mansard</author> <author>Nicolas Mansard</author>
<license>BSD</license> <license>BSD</license>
...@@ -13,6 +13,9 @@ ...@@ -13,6 +13,9 @@
<build_depend>git</build_depend> <build_depend>git</build_depend>
<build_depend>doxygen</build_depend> <build_depend>doxygen</build_depend>
<!-- The following tags are recommended by REP-136 -->
<exec_depend condition="$ROS_VERSION == 1">catkin</exec_depend>
<exec_depend condition="$ROS_VERSION == 2">ament_cmake</exec_depend>
<depend condition="$ROS_PYTHON_VERSION == 2">python</depend> <depend condition="$ROS_PYTHON_VERSION == 2">python</depend>
<depend condition="$ROS_PYTHON_VERSION == 3">python3</depend> <depend condition="$ROS_PYTHON_VERSION == 3">python3</depend>
<depend condition="$ROS_PYTHON_VERSION == 2">python-numpy</depend> <depend condition="$ROS_PYTHON_VERSION == 2">python-numpy</depend>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment