Commit 7dc6ed30 authored by Joseph Mirabel's avatar Joseph Mirabel Committed by Joseph Mirabel
Browse files

Update Makefile

* install hpp-walkgen
* install roboptim-core and roboptim-trajectory
*         and dep (liblog4cxx10-dev, libltdl-dev)
parent 0ad7f2c5
......@@ -46,8 +46,10 @@ To install all the packages on ubuntu 14.04 LTS 64 bit, you should do the follow
- libltdl-dev
- python-matplotlib
- libtinyxml2-dev
- liblog4cxx10-dev
- libltdl-dev
sudo apt-get install autoconf g++ cmake libboost-dev liburdfdom-dev libassimp-dev ros-indigo-xacro ros-indigo-kdl-parser ros-indigo-common-msgs ros-indigo-tf ros-indigo-tf-conversions ros-indigo-libccd ros-indigo-octomap ros-indigo-resource-retriever ros-indigo-srdfdom ros-indigo-pr2-robot flex bison asciidoc source-highlight git libomniorb4-dev omniorb-nameserver omniidl omniidl-python libltdl-dev python-matplotlib libtinyxml2-dev
sudo apt-get install autoconf g++ cmake libboost-dev liburdfdom-dev libassimp-dev ros-indigo-xacro ros-indigo-kdl-parser ros-indigo-common-msgs ros-indigo-tf ros-indigo-tf-conversions ros-indigo-libccd ros-indigo-octomap ros-indigo-resource-retriever ros-indigo-srdfdom ros-indigo-pr2-robot flex bison asciidoc source-highlight git libomniorb4-dev omniorb-nameserver omniidl omniidl-python libltdl-dev python-matplotlib libtinyxml2-dev liblog4cxx10-dev libltdl-dev
3. install dependencies of openscenegraph:
......
......@@ -38,6 +38,9 @@ hpp-corbaserver_repository=${HPP_REPO}
hpp-constraints_branch=devel
hpp-constraints_repository=${HPP_REPO}
hpp-walkgen_branch=devel
hpp-walkgen_repository=${HPP_REPO}
hpp-wholebody-step_branch=devel
hpp-wholebody-step_repository=${HPP_REPO}
......@@ -65,7 +68,6 @@ hpp-doc_repository=${HPP_REPO}
hpp-manipulation_branch=devel
hpp-manipulation_repository=${HPP_REPO}
hpp-manipulation-urdf_branch=devel
hpp-manipulation-urdf_repository=${HPP_REPO}
......@@ -107,6 +109,11 @@ hrp2: test-hpp.install
hpp-fcl.configure.dep: hpp-fcl.checkout
eigen3.configure.dep: eigen3.checkout
roboptim-core-3.1.configure.dep: eigen3.install roboptim-core-3.1.checkout
roboptim-trajectory-3.1.configure.dep: roboptim-core-3.1.install \
roboptim-trajectory-3.1.checkout
hpp-walkgen.configure.dep: hpp-util.install hpp-core.install \
roboptim-trajectory-3.1.install hpp-walkgen.checkout
hpp-util.configure.dep: hpp-util.checkout
hpp-model.configure.dep: hpp-util.install hpp-fcl.install \
eigen3.install hpp-model.checkout
......@@ -115,7 +122,7 @@ hpp-statistics.configure.dep: hpp-statistics.checkout
hpp-core.configure.dep: hpp-constraints.install hpp-statistics.install \
hpp-core.checkout
hpp-constraints.configure.dep: hpp-model.install hpp-constraints.checkout
hpp-wholebody-step.configure.dep: hpp-constraints.install \
hpp-wholebody-step.configure.dep: hpp-constraints.install hpp-walkgen.install \
hpp-wholebody-step.checkout
hpp-manipulation.configure.dep: hpp-core.install hpp-constraints.install \
hpp-manipulation.checkout
......@@ -250,6 +257,20 @@ eigen3.configure: eigen3.configure.dep
cd ${SRC_DIR}/eigen3/build; \
cmake -DCMAKE_INSTALL_PREFIX=${DEVEL_DIR}/install -DCMAKE_INSTALL_LIBDIR=lib -Dpkg_config_libdir=${DEVEL_DIR}/install/lib ..
roboptim-core-3.1.checkout:
if [ -d $(@:.checkout=) ]; then \
echo "$(@:.checkout=) already checkout out."; \
else \
wget -O - "https://github.com/roboptim/roboptim-core/releases/download/v3.1/roboptim-core-3.1.tar.bz2" | tar -xj; \
fi
roboptim-trajectory-3.1.checkout:
if [ -d $(@:.checkout=) ]; then \
echo "$(@:.checkout=) already checkout out."; \
else \
wget -O - "https://github.com/roboptim/roboptim-trajectory/releases/download/v3.1/roboptim-trajectory-3.1.tar.bz2" | tar -xj; \
fi
hrp2.configure: hrp2.configure.dep
. ${DEVEL_DIR}/install/setup.sh; \
cd ${SRC_DIR}/hrp2/hrp2_14_description;\
......
......@@ -23,7 +23,7 @@ sudo apt-get --assume-yes install wget
sudo apt-get --assume-yes install doxygen freeglut3-dev
# From here, it is a standard HPP installation
sudo apt-get --assume-yes install autoconf g++ cmake libboost-dev liburdfdom-dev libassimp-dev ros-indigo-xacro ros-indigo-kdl-parser ros-indigo-common-msgs ros-indigo-tf ros-indigo-tf-conversions ros-indigo-libccd ros-indigo-octomap ros-indigo-resource-retriever ros-indigo-srdfdom ros-indigo-pr2-robot flex bison asciidoc source-highlight git libomniorb4-dev omniorb-nameserver omniidl omniidl-python libltdl-dev python-matplotlib libtinyxml2-dev
sudo apt-get --assume-yes install autoconf g++ cmake libboost-dev liburdfdom-dev libassimp-dev ros-indigo-xacro ros-indigo-kdl-parser ros-indigo-common-msgs ros-indigo-tf ros-indigo-tf-conversions ros-indigo-libccd ros-indigo-octomap ros-indigo-resource-retriever ros-indigo-srdfdom ros-indigo-pr2-robot flex bison asciidoc source-highlight git libomniorb4-dev omniorb-nameserver omniidl omniidl-python libltdl-dev python-matplotlib libtinyxml2-dev liblog4cxx10-dev libltdl-dev
sudo apt-get --assume-yes build-dep openscenegraph
# Setup environment
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment